0

Problem: First, I see similar questions but everything points to a blinking cursor. I do not have a blinking cursor but black screen with a (non-blinking) underscore in the upper left OR I am stuck at grub.

Background: Elementary was working fine til yesterday on my iMac (wiped to run only Elementary) until I tried to run a Python script in attempting to install Proton VPN. It didn't work, but I continued to use the computer until I started it this morning and got the black screen.

Actions & results:

1)Start system with power button: Displays "System BootOrder not found" then loads the choices to do: a)Elementary OS> black screen; upper left non-blinking underscore

b)Advanced Options> Recovery Mode> a long output with a plain underscore (non-blinking), can't input anything (pic 1)

c)I can get to GRUB but after running everything I've seen in the past 3 hours on how to fix Elementary from Grub, I can do nothing. I can't get a Terminal screen either to run commands or even a shred or dd command (which is what I want to do at this point).

Unfortunately, I can't reinstall my Mac OS to wipe it all to reinstall the Elementary USB. Secondhand mac has DVD/CD drive but came with preloaded OS which I wiped, confident I'd love Elementary. I DO, but I realized I screwed something up trying to install Proton VPN yesterday and running the software update from Applications.

Any help much appreciated. I've tried all related solutions here but saw none with non-blinking cursor. I'd also appreciate how to wipe or DD or shred this system to start fresh since i already flashed the Elementary install on the disk. But again, it will not load from that (I've been researching for 3 hours and see no way to do that without access to Terminal since I'm stuck in Grub).

2
  • If I boot from my Elementary USB install, I get the same results: I get Elementary splash and choice to E or install--it lands me at black screen with nonblinking underscore in upper left, C for command puts me at grub instead of terminal. Thx
    – user20191
    Jan 8 '20 at 19:15
  • At grub, if I try to run boot, I'm told I need to load the kernel first. I have also tried Tabbing through commands, have identified both my hard drive (H0) and USB install of Elementary (H1) with ls command and tried to root them from this site's instruction (unix-ninja.com/p/Manually_booting_the_Linux_kernel_from_GRUB) but I don't know filename and tabbing to complete command lines yields nothing. Thank you. Tried 5 other sites and getting nothing from grub commands.
    – user20191
    Jan 8 '20 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.