Elementary 5.1 Hera NetworkManager v 1.10.6 Lenovo Yoga 13 inch, Intel i5

My NetworkManager randomly drops wifi communications. Wifi signal strength drops to around 50% but a connection is indicated but there nothing loads into a browser, Firefox v 71.0 in this case.

Tried turning off power management but no joy.

Wifi adapter is RTL8822BE 802.11a/b/g/n/ac. I installed the latest driver but again no joy.

I noticed from the journalctl output that NetworkManager is unable to open /run/network/ifstate because that directory and file does not exist on my system.

I have a persistent USB version of Zorin which does not have the same or similar issue. I noted that Zorin does have /run/network/ifstate installed.

Does anyone have a permanent solution to this problem?

1 Answer 1


I have the same adapter (in a Lenovo Legion Y530) and I had to turn aspm off for the wireless adapter.

Create a new r8822be.conf file in /etc/modprobe.d/, with the following contents:
options r8822be aspm=0
After this, I also had to turn off the laptop, unplug the charger, wait for a few minutes, and turn it back on. No more wireless issues after this.

  • I tried this suggestion but it did not produce an improvement in stability. Jan 9, 2020 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.