For some reason since yesterday the tab key option for auto fill is not working properly in the terminal. I have also noticed the user name color has changed to grey (not sure if it has something to do but that happened at the same time the auto fill stop working).


If I write down sud and then tap the tab key, sudo command is auto filled properly.

However in this case sudo apt inst, the tab key does not work and you can hear the Terminal bell.

About Terminal

Please let me know if you need any other information. Thanks for your help.

3 Answers 3


Can you tell if the problem is specific to io.elementary.terminal (the default elementaryOS terminal GUI), or is it the Bash shell in general?

Try keyboard combo Ctrl-Alt-F2 to switch to another virtual console (TTY), log in as the same user, and try using Tab Completion there. If you haven't switched TTY before, remember that by default pressing Ctrl-Alt-F7 will return you to your graphical (GUI) session.

If Tab Completion doesn't work in another virtual console either, then you may have an issue with your Bash configuration. If that's the case, try checking out the following thread from the Ubuntu support forums: https://askubuntu.com/questions/33440/tab-completion-doesnt-work-for-commands.

  • I have followed your steps and tried with TTY. After I logged in I tried installing some apps or work on a git project and everything was perfect. It seems the problem is only with the elementaryOS terminal. Commented Jan 4, 2020 at 23:20
  • 1
    Okay. Next, let's try it from another user account if possible. Try enabling the guest account or adding a temporary account to test with. It'd be good to know if it's a system-wide issue, or if it's isolated to just one user profile.
    – curiouser
    Commented Jan 5, 2020 at 17:09
  • It seems to be just my profile. I created a new user and the terminal was working perfect. The username was on green color and the tab key was behaving as it is supposed to be. Commented Jan 6, 2020 at 6:26
  • I'd take a look at the .bashrc file then. Compare the test profile's working one with your own account's, and see if any of the options look different. diff /home/yourprofile/.bashrc /home/testprofile/.bashrc. You can try adjusting your bash config options if you notice something out of place. You could even try copying over the config from the test profile to your's (after making a backup of your original file first, of course.) If the problem doesn't exist within the .bashrc file, then it may be time to try technicallyblue's suggestion about reinstalling the terminal application.
    – curiouser
    Commented Jan 6, 2020 at 23:05
  • Well... the problem was indeed, there was not a .bashrc file in my profile. After I copy it from the testprofile to my profile everything began to work again. Thank you very much for your help! Commented Jan 7, 2020 at 1:09

I would check the AppCenter. I just received a notice to update the terminal. This could fix whatever config broke that disabled your tab function.

  • I did it yesterday. Still doesn't work. Commented Jan 4, 2020 at 23:13
  • 1
    Alright, then I would take a look the link curiouser provided about the bash config. You could force it to work with the config or determine which update caused the the autofill to stop working and roll it back. Last resort, after everyone else answers is "sudo apt install --reinstall pantheon.terminal" Commented Jan 5, 2020 at 20:57

This problem was solved by @curioser (comments section above)

The problem was caused by the /home/myprofile/.bashrc file. For some reason it was not there. I took it from another profile and just copy/paste it to mine. The Terminal began to work properly immediately.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.