1

Hoping somebody can help

I have a dell G5 5587 laptop running Hera, I have connected to external monitor via HDMI cable.

when the laptops lid is closed I can work on the external. when the laptop gets suspended I can wake it up with USB connected keyboard/mouse

It wont however automatically start the display on the external monitor, i need to open the laptop and login and then it will.

Any solution?

1

Instead of closing the lid of the laptop you can use the cycle display modes shortcut Super+p. On both of the laptops I use there is such a function key also. If I do it like this after the resume of suspend it enables the same monitor as before the suspend. Also, if you want to skip logging in on wakeup, you can set this using System settings > Security & Privacy > Locking

  • This is not an answer. – duality Jan 7 at 16:58
1

The idea would be to tell lightdm to use the same settings that you use for the monitors.

So, login into elementary with the external monitor connected, set up your displays the way you want in System Settings -> Displays (mark the external display as primary by clicking its star in the upper left corner). Save you configuration.

Now, copy the ~/.config/monitors.xml file to /var/lib/lightdm/.config/ (you'll need sudo for this).

Reboot and hope for the best.

Another way is detailed here Multi-monitor config for greeter

EDIT: if using cp to copy the file, you'll have to use the --remove-destination flag to avoid the cp: not writing through dangling symlink warning:
sudo cp --remove-destination ~/.config/monitors.xml /var/lib/lightdm/.config/

  • The first instruction gave worked when rebooting, but did not solved the problem of wakup from the suspended state to external monitor. – duality Jan 9 at 11:54
  • Does it work if you power-cycle the external display before waking up the laptop from sleep? – Vlad Pop Jan 9 at 12:04
  • 2
    @duality, hello! Please don't flag answers for technical issue, instead make a comment for clarification if need. Have a nice day! – Hasan Jan 9 at 12:58
  • Sorry, I’m relatively new to stack exchange. I will comment on future from now on, thank you – duality Jan 11 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.