0

I just updated my ElementaryOS from Juno to Hera. When I open System Settings and try to open Tweaks. This closes the entire System Settings window and does not open the Tweaks window.

1

You have to update elementary-tweaks package also in order to work with Hera. When the update to Hera was released, elementary tweaks behave like you explain, but after a while it was updated also and now it works as before, only slingshot options for raws and columns are missing, because it was removed from the OS, only 5x3 grid is presented at the moment. Execute sudo apt update && sudo apt upgrade into terminal.

Another possibillity is that you have set something before the update which is not supported now. I can advice you to remove all you settings made by elementary-tweaks by purging and reinstalling it. In order to do that, execute

sudo apt purge elemetnary-tweaks

if you do not have purge installed, you can do this by sudo apt install purge. After purging install it again:

sudo apt install elementary-tweaks
| improve this answer | |
  • I have tried to update with sudo apt && sudo apt upgrade. Still not working. I tried sudo apt install element-tweaks --reinstall, it still doesn't work. Can you tell me how to run elementary tweaks via terminal? – Wilman Darnasutisna Dec 28 '19 at 17:21
  • hmm.. it is strange. I do not know an option to run it from terminal, sorry. Probably you are using the same source, but to double-check - do you isntall it using this repository - github.com/elementary-tweaks/elementary-tweaks#installation ? – Bo rislav Dec 29 '19 at 12:16
  • Yes, i'm suing that repo. I can't find anything in google about how to run tweaks on terminal. That's weird. I thought everything can run on terminal to check the error. – Wilman Darnasutisna Dec 29 '19 at 14:56
  • Probably there is a terminal command, but I never see it also. I can recommend you to check out the issues into the github link I posted above, probably there will be something that can help you. This is a fork of the original repository of elementary tweaks and you can post an issue there. Another option you may try is to purge (remove elementary tweaks with all options) sudo apt purge elementary-tweaks and install it again - you will loose your current settings made by the elementary tweaks, but I believe there is the problem, something not supported now is set there. – Bo rislav Dec 29 '19 at 15:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.