0

since today my Marshall Major 3 can't be connected to my laptop. I never had any issued until today, but now i only can appair to it, and when i try to connect to my hedset i have the error:

impossible connection

My headset works fine with my phone, so i really think the problem comes from Elementary...

ps: I have an Huawei matebook D if that can help

edit:
journalctl returns the following response each time I try to connect to my headset:

bluetoothd[10401]: a2dp-sink profile connect failed for 2C:4D:79:C1:3E:11: Protocol not available

Also, i can't remember which command I've typed for that, but I saw some segfault reffereing to the bluetooth. I know it's not very useful.

I searched some fixes for the "Protocol not available" issue, and a possible fix would be to install "pulseaudio-module-bluetooth", but when I try to install it, i get the following error:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:
pulseaudio-module-bluetooth :
Depends: libpulse0 (= 1:11.1-1ubuntu7.4) but 1:11.1-1ubuntu7.5 is to be installed
Depends: pulseaudio (= 1:11.1-1ubuntu7.4)
E: Unable to correct problems, you have held broken packages.

  • Are you able to provide some related logs from syslog or journalctl? – endorama Dec 24 '19 at 16:39
  • Sorry for the late reply. I've edited my original post with these informations. – Keylinsky Dec 29 '19 at 9:34
1

This fix is surely dirty, but it worked for me

I managed to resolve my problem;
The problem was libpulse0 which has been upgraded to the version 7.5 while the required version was the 7.4.

I've reinstalled the 7.4 version:

sudo apt install libpulse0=1:11.1-1ubuntu7.4
sudo apt-mark hold libpulse0

(apt-mark hold is used to prevent the upgrade of libpulse0 in the future)

After that, when I restarted my laptop i could no longer login (session returned 1), so I installed "pantheon-xsession-settings" (press ctrl+alt+f1 to enter in the terminal mode), rebooted and everything worked fine. (and so the bluetooth)

I think the installation of libpulse0 v7.4 removed some important packages, that's why I had to install "pantheon-xsession-settings"

|improve this answer|||||
  • I run apt install --dry-run libpulse0=1:11.1-1ubuntu7.4 and indeed it seems to remove stuff like elementary-desktop, gala etc. I also noticed that io.elementary.cerbere is listed as no longer needed, which is odd. I think I will file a bug report. – jena Feb 19 at 17:52
  • So I've found a bug that might be related, I added some info there: github.com/elementary/switchboard-plug-bluetooth/issues/… – jena Feb 21 at 11:02
0

Open terminal and type

sudo apt install blueman

sudo apt install nano

sudo nano /etc/bluetooth/main.conf 

Change #AutoEnable=false to AutoEnable=true (at the bottom of the file, by default)

Save using ctrl+x Exit

sudo service /etc/init.d/bluetooth

or

sudo systemctl enable bluetooth

sudo systemctl start bluetooth 
|improve this answer|||||
  • Thanks for your answer, but AutoEnable was already set to true – Keylinsky Dec 24 '19 at 10:09
  • Did you do all steps I mentioned or only you switched AutoEnable to true? – Sysadmin Dec 24 '19 at 10:14
  • AutoEnable was already to True so I didn't switched it, but I still executed the commands you gave – Keylinsky Dec 24 '19 at 11:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.