Io.elementary.greeter Starting the session has failed

Details : Session Returned error code 1

Can someone please tell me why this is happening????? I can't login and there are so many projects I have on this that I need to use !!

I went into the command line and there was an ACPI error that kept on coming up saying

ACPI BIOS Error(bug): Could Not Resolve [_SB.IPPF._STA.POS1], AE_NOT_FOUND (psargs-330)


I too am facing the same issue. I do all of my coding work on eOS and it's all stuck there now.

This happened after the recent update to eOS 5.1.2

I can still boot into my Windows 10 (dual boot setup).

Do I have to reinstall it or is there some workaround?

Edit: Solved it by following the directions someone had posted somewhere else. Here's the solution: After being returned the error Ctrl+Alt+F1 login with your username and password "rm .Xauthority" "sudo apt-get install pantheon-xsession-settings" Ctrl+Alt+F7

Restart. Hope it helps

  • Because .Xauthority is owned by a root after update. chown username:group .Xauthority solves the issue. For example chown robert:robert .Xauthority – Sysadmin May 9 '20 at 9:52

Try this :


Edit /etc/default/grub and add in GRUB_CMDLINE_LINUX_DEFAULT line AFTER quiet word these:

vga=current loglevel=3 rd.systemd.show_status=auto rd.udev.log_priority=3

Next update grub :

sudo update-grub

Last thing is creating SYSCTL rule:

sudo bash -c "echo ‘kernel.printk = 3 3 3 3’ > /etc/sysctl.d/20-quiet-printk.conf’"

and reboot.

sudo systemctl reboot

This will just HIDE error msgs during boot, still exists in dmesg results.

  • Doesn't seem to work – AiSirachcha21 Dec 24 '19 at 1:09
  • You should be running at least kernel version 4.18.0 (cat /proc/version*) because that included a fix that allows kernel to try to proceed even with errors while loading ACPI tables. Older kernel versions will stop loading the whole table in case of any error. And note that if older kernel version does not emit errors, it does not mean that it did work correctly - it probably just didn't even try to load those tables. Eventually it can work from 4.15. The other solution is to upgrade the BIOS. And the last one option is to disable ACPI in grub. – Sysadmin Dec 24 '19 at 6:48
  • GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=noacpi” – Sysadmin Dec 24 '19 at 6:53
  • I didn't try updating the OS. But I did try disabling the ACPI in the Grub menu but that didnt do anything – AiSirachcha21 Dec 25 '19 at 5:55
  • Try to upgrade the OS sudo apt update && sudo apt upgrade && sudo apt dist-upgrade – Sysadmin Dec 25 '19 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.