3

I have just installed elementary Hera. But I have one problem every time I shutdown my PC I get the following message:

~a stop job is running for session c2 of user xxx~

Then the 90 seconds timer counts down and I have to wait.

Any idea how to fix this?

Thanks in advance.

  • 1
    May you try looking at this other answer unix.stackexchange.com/questions/273876/…? I feel your issue is not directly related to elementary, so you can find useful help in other resources. – endorama Dec 23 '19 at 10:43
  • I researched a bit and found this: gist.github.com/dianjuar/98d02af4050dc2df8ae6f18695d44ca3 but I'm unsure whether this is a real solution... :-/ – Anonym Dec 23 '19 at 12:41
  • Have you tried looking at the logs after a shutdown? Journalctl persist logs from previous boot sessions. Follow the steps described here: unix.stackexchange.com/a/496563/111295 Maybe you will find something helpful? – endorama Dec 24 '19 at 16:27
  • Ok I have tried this Journalctl thing. The following processes were killed: the last three times: ~session-c2.scope: Killing process 4989 (io.elementary.c) with signal SIGKILL.~ one time: ~cups-browsed.service: Killing process 879 (cups-browsed) with signal SIGKILL.~ – Anonym Dec 30 '19 at 13:49
  • 1
    Oh I have looked in the github link, on the screenshots they also have this "io.elementary.c" inside, so I assume that this could be the same thing. Thank you for this hint! – Anonym Jan 1 at 22:46
2

I had the same problem and could not find a solution, you can set the timer to a smaller value in: /etc/systemd/system.conf. (If it is empty, here is a copy: https://p.ip.fi/bZfs)

Uncomment line DefaultTimeoutStopSec=90s then change it to a lower value. Then run systemctl daemon-reload

Hope it helps...

| improve this answer | |
  • 1
    I also have this issue, and managed to identify cerbere as the culprit. Still, no idea how to fix it. What's worse is that it does not happen all the time. – Vlad Pop Dec 23 '19 at 3:59
  • Thanks for your help. But reducing the timeout is the last chance if I don't find any other solution to fix this. – Anonym Dec 23 '19 at 12:44
  • Yes, for me also is cerbere, sometimes it is Gala (?!?) and no idea how to fix it.. So my 'solution' is also to reduce the timeout time. – Bo rislav Dec 23 '19 at 17:49
  • I have tried to edit /etc/systemd/system.conf. But the file is empty?!? – Anonym Dec 30 '19 at 14:17
0

See comments from : This problem is an open issue on github --> github.com/elementary/cerbere/issues/35

| improve this answer | |
  • PS: is perfectly acceptable to answer your own questions! Feel free to flag this as the accepted answer to aid future readers. – endorama Jan 21 at 15:48
  • The problem was fixed for some month and since updates from yesterday (29.05.2020) I have again this "a stop job is running for session c2 of user xxx" message and have to wait 90 seconds. The liked github archive was closed... – Anonym May 30 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.