0

After I changed my user from administrator to standard user to setup Parental Controls on my own account, which was the first account I created on my fresh installation, I could not login with the same password I used before (To setup Parental Controls I created another account called Admin and gave it admin rights, then through that user, I changed my own user to standard, which I reverted and deleted that Admin account after this problem). I'm pretty sure it has nothing to do with the keyboard layout because I can login through the login screen of Ctrl+Alt+F1. And the reaction of the password bar is different than when the password typed is wrong. Because if it is wrong it shakes after a second or two delay, but when I type my correct password, it shakes immediately. So far I tried deleting and checking the ownership of ~/.Xauthority, in separate occasions, but it did not work.

Also I can log in automatically eventhough the toggle of "log in automatically" in user accounts settings is turned off, and when I try to turn it on and reboot, it turns off again, yet I can still log in automatically.

I'm on elementary OS 5.1 Hera. I looked around the web but couldn't find any solutions, hope you can help me.

  • Check /etc/groups /etc/shadow and /etc/passwd see on my website how to change user passwords, groups etc. sysadmin.info.pl The last option is to enter the rescue mode and change the root password, and after that use root to change password for all users with passwd. Hope this will help. – Sysadmin Dec 23 '19 at 21:24
  • Are you referring to this [sysadmin.info.pl/en/… tutorial? If so, I didn't understand what you were doing as the instructions were in polish. I tried using passwd command to change (well, not really change, I typed in the same one) my password but that didn't work either. Could you give me english instructions? Also there is no /etc/groups file or folder, did you mean /etc/group or /etc/group- ? – coolbeans Dec 24 '19 at 18:07
  • Follow this guide to be able change the passwd for user: How do I reset a lost administrative password? – Sysadmin Dec 25 '19 at 9:31
  • Follow this guide to be able change the passwd for user: askubuntu.com/questions/24006/… – Sysadmin Dec 25 '19 at 9:37
  • unfortunately, both top answers for that question did not work, I still can't get Greeter to accept my correct password. I'm thinking about reinstalling eOS at this point. Do you have any other suggestions? – coolbeans Dec 25 '19 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.