0

I have a dual boot with elementary OS and Windows and somehow I wasn't able to enter Windows and Grub rescue appeared.

I entered set root=(hd0,msdos4)/@ and set prefix=(hd0,msdos4)/@/boot/grub as I found on q&a board. After I entered insmod normal but there was an error: unknown filesystem. I rebooted and could enter Windows at this point. I then tried to enter elementary OS but it was some error telling "can't read outside hd0" iirc. I read that I also need to update grub, that's why I was trying to get in on elementary OS.

I figured I set it too narrow for multiple systems so I went and entered in grub rescue set root=(hd0), set prefix=(hd0)/boot/grub, and then insmod normal, normal without any errors this time. After this I did a reboot and now facing 'Read error' not being able to enter grub rescue again. I'm trying to recover it in terminal from USB now but I believe I can only see my USB drive from there.

Here is the boot info I got: https://paste.ubuntu.com/p/9fY5w3gnXT/ with flash drive in.

My HDD is 500GB which is not displayed. But it displays in BIOS. Somehow I managed to get into Windows after creating Xindows live USB with Unetbootin (grub menu appeared), everything was slow and after rebooting I was unable to replicate it and load Windows again.

How do I get the system back?

2
  • 2
    solved by hard changing sata port Dec 15 '19 at 14:42
  • can you put the comment above into an answer and after some necessary delay to accept it in order to be visible in stackExchange system that the problem is resolved? It can be helpful for someone else in a situation like yours.
    – Bo rislav
    Dec 15 '19 at 23:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.