0

I am having problems with internal microphone on elementary OS 5.1 Hera(based on Ubuntu 18.04.3 LTS). Linux is not detecting the internal microphone. If I plugin a headphone with microphone, it will be working fine. Also there is no problem with the internal speakers.

sudo pavucontrol

screenshot

I have tried all the methods specified here.

Also I have tried editing /etc/modprobe.d/alsa-base.conf with options snd-hda-intel model=dell which didn't worked as well.

Following are the output for head -n 1 /proc/asound/card0/codec*:

==> /proc/asound/card0/codec#0 <==
    Codec: Realtek ALC3254

==> /proc/asound/card0/codec#2 <==
    Codec: Intel Kabylake HDMI

Here is my Alsa logs.

Do anyone have any ideas to solve this?

  • Your kernel is up to date with version 5? – LinkPhoenix Dec 15 '19 at 9:20
  • Yes, I have updated the kernel as well – Jithin Jiji Dec 16 '19 at 10:01
  • I can confirm the issue on Dell Inspiron 7590 with Ubuntu 18.04 – Кристиян Кацаров Feb 25 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.