Just got my new Dell XPS 13 (7930) developer edition with Ubuntu 18.04 preinstalled, and want to install Elementary OS 5.1. I flashed the OS onto a USB, booted into the USB and I get the following error message:

This Dell REcovery Media can be used to restore the original factory software. 
It is recommended you back up all important data before running this tool.

ERROR: This recovery media only functions on Dell and Alienware 
systems purchased with Ubuntu.

So somehow it launches a Dell recovery program. I made sure the correct USB stick is selected.

What might cause this?

I have checked/tried so far:

  1. The SATA mode in BIOS options is set to AHCI
  2. Create live USB using mulitple methods/computers/operating systems
  3. Confirmed the live USB works fine by trying to install it to my old XPS 13 9343 - no issues there
  4. Tried the nomodeset option from e.g. elementary OS won't boot past live CD screen - this resulted in a black screen

enter image description here

  • try changing SATA settings in laptop bios to AHCI
    – duality
    Commented Dec 14, 2019 at 12:06
  • the same happens to me. I will try changing sata settings and I will let you know Edit THere is only one settings for SATA and it is only AHCI. So I tried again and again, the ony thing I could start is a live session user with a UBUNTU 18.04 default live session. No luck at all. Commented Dec 14, 2019 at 12:08
  • The setting was already on AHCI, since it already was a Linux machine.
    – Inigo
    Commented Dec 14, 2019 at 14:16
  • 2
    @Inigo I'm stuck at the same issue. Trying to boot into elementary OS (which is on a USB stick), but always end up in this DELL Recovery Screen. Did you manage to boot anything other from USB? Commented Jan 10, 2020 at 17:14
  • 2
    Can we re-open this please? It's not a duplicate of the linked question, they have very different symptoms. I'm having this problem currently (going to a dell recovery screen) but the linked question is about a black screen problem and it doesn't apply.
    – Segfault
    Commented Feb 23, 2020 at 3:41

3 Answers 3


I think that either your bootable USB key was not well done or you did not activate the AHCI mode of your DELL, but I think that it is already configured low on the Dell Developper edition

Maybe this links can help you

Personal experience of installing Ubuntu 18.04 LTS on XPS 15 9570

XPS 13-7390 2 n 1 Cannot Boot Fedora 30 Live USB

How to Install Ubuntu Linux on your Dell PC

On my two XPS 13 I just had to activate the AHCI mode, and on one to deactivate Bitlocker before, but that should not be your case. By quickly reading some of the links above it would seem that for your model you will need to do some additional manipulations.

Recommended action

  • Update your BIOS
  • Backup your Ubuntu if you need it
  • Activate AHCI mode
  • Create your USB live with this tutorial here
  • If it doesn't work, look at the links above

hope it will help you and you can, like me, enjoy a super elementary OS on a DELL XPS

  • Thanks for your answer. AHCI mode is already on (indeed, because of the developer edition), BIOS is updated (version 1.3.1) and I created the live USB using 1) the link you sent (from elementaryos) and 2) using Ubuntu's startup disk creator. I'll try to dig further.
    – Inigo
    Commented Dec 14, 2019 at 14:19
  • Update: tried to create the USB from Windows this time, didn't help. Also tried the nomodeset option but that resulted in a black screen as with most people. I don't have an option to boot in legacy mode with my current bios.
    – Inigo
    Commented Dec 14, 2019 at 15:21
  • If you use Windows i recommand to you to use RUFUS, and create your usb with target BIOS UEFI and maybe Partition schem GPT Commented Dec 14, 2019 at 15:39
  • Yes, I did it using the Elementary OS website guide, using Rufus. I don't think the issue is the USB, more some setting in my BIOS or GRUB loader. Not solved yet.
    – Inigo
    Commented Dec 14, 2019 at 15:52
  • 1
    I'm having this problem now and these steps aren't helping. The Ubuntu 18.04 live cd works fine, it's only the elementary OS 5.1 live cd that has this problem.
    – Segfault
    Commented Feb 23, 2020 at 18:50

removing hidden ubuntu partition allowed to install elementary. hopes it help. greetings

  • 1
    Your participation is much appreciatedđź‘Ť Let me inform you that we love informative answers with step by step guide. Please try to post detailed information so that it is simple enough for someone with zero technical knowledge to easily understand.
    – Hasan
    Commented Jun 1, 2020 at 7:58
  • If wasn't clear, it is not simple to understand How to remove the hidden ubuntu partition, so please write down the steps how to do it.
    – Kerek
    Commented Aug 24, 2020 at 21:00

I used this how to https://www.easeus.com/partition-manager-software/find-hidden-partition-or-hide-partition.html

Step 1. Right-click on This PC/My Computer and click on "Manage".

Step 2. Select the volume without a drive letter, the partition which you've hidden previously. Right-click it, select "Change Drive Letter and Paths...".

Step 3. Click "Add" to assign the drive letter for the partition to unhide it.

Unhide partition.

Step 4. Assign the drive letter for the hidden partition, such as F, and hit "OK". Then your hidden partition will show up in PC and work as a normal partition to store data for you again.

Once i can saw it (that ubuntu named hidden partition) i format it. Then i booted elementary from usb. This worked for me. Hopes it helps.sorry for my English

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.