1

System Specs

System:
Host: elementary-2950x
Kernel: 5.0.0-37-generic x86_64 bits: 64
Desktop: Gnome Distro: elementary OS 5.1 Hera
Machine:   Device: desktop
System: PC Specialist
  product: Amd X399 Overclocked serial: N/A
Mobo: ASUSTeK
model: PRIME X399-A v: Rev 1.xx
serial: N/A
UEFI: American Megatrends
  v: 1203
  date: 10/09/2019 Battery
  hidpp__0: charge: N/A condition: NA/NA Wh
CPU: 16 core AMD Ryzen Threadripper 2950X (-MCP-)
  cache: 4096 KB
Graphics:  Card: NVIDIA Device 1e04 (RTX2080Ti) Display Server: x11 (X.Org 1.20.4 )
  driver: nvidia
  Resolution: 3840x2160@60.00hz, 3840x2160@60.00hz, 3440x1440@59.94hz
OpenGL:
  renderer: GeForce RTX 2080 Ti/PCIe/SSE2
  version: 4.6.0 NVIDIA 435.21

enter image description here

Here is an image of the Display Manager and you can clearly see 1440 chosen and yet the display does not change to 1440.

Please let me know if you need any further config info.

Nvidia-settings had been previously set to all three monitors in 1440 and xorg.conf saved on /etc/X11

the monitors change back to native resolutions on every reboot of the system

Kind Regards Zeb...

  • I saw that you had a hard time putting your image on your question, for that you just have to drag and drop your image on the text section and add it, it will be automatically hosted on IMGUR and the link will be automatically add in the correct format in your response. For your issue you did you try to change the resolution go back to the desired resolution and validate? – LinkPhoenix Dec 14 '19 at 16:24
  • Thank you I will remember that for next time – Zebedee Boss Dec 14 '19 at 22:03
0

Not sure it will going to work, but if I am in your place I will do a backup of ~/.config/monitors.xml, open it in some editor (elementary Code for example), change the resolutions there and restart the computer. If this leads you to a problem, you can delete the file into recovery mode or tty and restore it from the backup.

To create a copy of the file:

cp ~/.config/monitors.xml ~/.config/monitors.xml.bak

To restore the file from tty:

pres Ctrl+alt+F2, login with your username and password and execute:

rm ~/.config/monitors.xml && mv ~/.config/monitors.xml.bak ~/.config/monitors.xml

To restore the file using Recovery mode:

Select advanced options for elementary OS from the grub boot screen, then the first option with (recovery mode) into the name. Wait until the menu appears, choose Root shell. There you have to navigate to your user folder and restore the file, replace YOUR_USER_NAME below with your username folder.

cd /home/YOUR_USER_NAME/.config && rm monitors.xml && mv monitors.xml.bak monitors.xml
  • I did a test this week for a person who had a problem of resolution, I edit this file but it does not bring any effect on the screen after reboot and yet it is a file which is modified by DISPLAY – LinkPhoenix Dec 15 '19 at 1:11
  • sometimes there is one more file also, monitors.xml~ . Inside these files are saved resolutions of the monitors and different setups, which you can switch by pressing Super+p. I had a problem in Loki, cannot move the plank into the monitor I need, it switches the resolution to some really lower, so I have edit this file, replace the primary monitor and after the restart everything was ok. – Bo rislav Dec 15 '19 at 1:15
  • Hi, I tried the .xml method however... I get this in a terminal zebedee@elementary-2950x:~$ cp ~/.config/monitors.xml ~/.config/monitors.xml.bak cp: cannot stat '/home/zebedee/.config/monitors.xml': No such file or directory zebedee@elementary-2950x:~$ Thanks for trying to help though :) – Zebedee Boss Dec 15 '19 at 13:41
  • 1
    I have a simple solution and I created a 1440.sh file to set the resolution I want but it is not perfect. > #!/bin/sh -e # # This script is to bypass the nvidia blues and the desktop not starting on reboot sleep 2s nvidia-settings --assign CurrentMetaMode="DP-2: 2560x1440 +6000+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-4: 3440x1440 +2560+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-0: 2560x1440 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}" – Zebedee Boss Dec 15 '19 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.