0

Installed update libpoppler85 Version: 0.74.0-0ubuntu1.2 from the AppCenter.

Next thing I realize my stock elementary file manager is no longer installed. Tried reinstalling, but it gave me an error of broken packages. Tried to fix broken packages from synaptic, still doesnt work.

Problem solved after downgrading back to libpoppler85_0.74.0-0ubuntu1.

Just posting if anyone having the same problem or if there's an fix for this.

PS: I'm new to eOS and linux in general.

  • Have you installed any PPAs? Hera does not supply libpoppler85 - it supplies libpoppler73 as far as I understand. – Jeremy Wootten Dec 14 '19 at 10:37
  • Nothing recently. My file manager went missing after an update from App Center. Next thing i know the app 'files' was uninstalled, and reinstalling gave me a libpoppler85 dependencies error. – MaddPenguin Dec 15 '19 at 12:19
2

Welcome in elementary OS community

I don't know what is libpoppler85 but I think is dependencies package from specific apps but I don't know but which one.

For repair broken package you can do that

$ sudo apt update --fix-missing

or

$ sudo apt install -f

personally I often use the second command following the manual installation of a .deb to install dependencies

For more information you can follow @Duality's link How to Fix Broken Packages in Ubuntu

INSTALL PACKAGE LOCALLY

$ sudo apt install ./PACKAGENAME.deb
$ sudo apt install -f

DOWNGRAD PACKAGE

I saw that you solved your problem by downgrading your package, I think you had to do something like that

$ sudo apt-get install libpoppler85=0.74.0-0ubuntu1

OR

$ sudo apt-get -t=0.74.0-0ubuntu1 install libpoppler85
| improve this answer | |
  • i did manually reinstalled the libpoppler85, and that did fixed the problem. But AppStore still prompt me for libpoppler85 update, and installing update would once again broke my file manager (broken dependencies). – MaddPenguin Dec 13 '19 at 14:06
  • Why do you need to get package and how did you find it on the AppStore because I do not know how to get package, for me it is an addiction that is installed when you wanted to install a specific application. I think I could better edit my answer if I knew when you had this dependency problem, with what application exactly. – LinkPhoenix Dec 13 '19 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.