After installing wingpanel-indicator-ayatana (available via some answer here) and rebooting, I've got two wi-fi indicators (ss below) How can I get rid of one of them? Is there any way possible? I don't want to uninstall the indicator app because of dropbox, which I use daily. enter image description here

Found This on reddit, will try it out just appending .old at the end of the name of the file.

  • Do you solve your problem if yes it is better if you answer yourself and valide your answer Commented Dec 11, 2019 at 18:33

4 Answers 4


Found This on reddit

Delete nm-applet from here:


I didn't delete it, just append .old at the end of the filename

  • Yes. sudo mv /etc/xdg/autostart/nm-applet.desktop /etc/xdg/autostart/nm-applet.desktop-old worked for me. Commented Jun 3, 2020 at 20:03

It's actually quite simple. Run the following commands.

sudo nano /etc/xdg/autostart/nm-applet.desktop

Find the following line.


Change it to the following instead.


Then save, and restart. That's it!


I wouldn't recommend disabling it or you might loose some functionality for advanced WiFi settings. Simply edit file /etc/xdg/autostart/nm-applet.desktop and add --no-indicator flag in Exec line:

Exec=nm-applet --no-indicator.


Another way to solve this would be to comment out a line in the nm-applet.desktop file. In Terminal, do this:

sudo nano /etc/xdg/autostart/nm-applet.desktop

Then add a # to the line that looks like:


It should now look like:


You will probably need to log out, then log back in before this change is seen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.