0

After a recent update and apt autoremove, the Elementary OS files app was somehow removed. I tried to reinstall it from the appstore, only for it to complain that tumbler and tumbler extras needed installing (for thumbnail viewing, I presume?) but weren't going to be installed. I tried to install it from the terminal, but received the warning that libpoppler-glib8 (>= 0.18.0) was needed but wouldn't be installed with a message:

E: Unable to correct problems, you have held broken packages.

I tried to apt install libpoppler-glib8 but received a similar error saying that libpoppler85 was a dependency but wouldn't be installed. Tried the same for libpoppler85, but it simply says that it's already installed and the latest version.

I installed the GUI Synaptic package manager and tried to install tumbler there, but same issues. I tried

sudo apt clean

and

sudo apt install -f

and then updated but with no results. Something is wrong with my dependencies tree? Any suggestions?

0

Has this same problem. Latest libpoppler85 (0.74.0 ubuntu1.2) caused this for me. Reverting back to libpoppler85 (0.74.0 ubuntu1) fixed it for me for the moment.

| improve this answer | |
0

Looks like you have the wrong version of one of the dependencies (or dependency of a dependency ...) in the repository stopping Files being re-installed. Not clear how this happened. Are you running ElementaryOS? Which version? Did you make any amendments to the repository settings or install new ones? Did you make a clean install of the OS or is it upgraded from a previous version. It may be quicker in the long run to save all your data to external media, make clean install of the OS and then reinstall your data. Elementary does not really support upgrading from the previous version as far as I am aware.

| improve this answer | |
0

So I thought about Jeremy's comment on wrong versions of dependencies, so I used the Synaptic software manager to reinstall libpoppler85, and that rectified the versions. I was able to simply download Files from the appstore after that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.