On elementary 5.0 I had perfect tackpad support on my Razer Blade Stealth 2016.

After updating to 5.1 my trackpad no longer works. I've searched through these forums and others for solutions but nothing so far has come up.

I've tried uninstalling and reinstalling the xorg-synaptics driver a few times. I tried reinstalling the whole OS from a 5.0 live USB and then upgrading from a clean install, and that still breaks trackpad support. Just looking for some tips.

Thank you!

1 Answer 1


Many people have their touchpad that does not work anymore or badly after updating to elementary OS Hera 5.1

Question 1

Question 2

The solution has trouble, as you can see in the discussion is to update the Kernel. Can you confirm that this is the same for your computer model?

$ sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

Hope this will solve your problem

  • Thank you! I will definitely try that. I believe I missed those answers because I was searching "trackpad" and not "touchpad" my mistake and I apologise for taking up people's time!
    – Landonn
    Dec 10, 2019 at 0:10
  • No problem, you realized that there were two key words. I am French and after you answered it is true that even in my answer for this subject I can be confused TrackPad and TouchPad. I hope that the answer will help a maximum of people who have updated their OS under Elementary OS 5.1. Do not forget to validate the answer if that also solves the problem on your model of PC it is possible for X reasons that it is not the case. Dec 10, 2019 at 0:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.