1

I was installing Google Chrome on my elementary OS from installer and due to unmet dependencies i run

sudo apt-get install -f

Don't know what happened i just it was saying

removing Pantheon-files

and as a result now i am not able to use elementary OS. As every time i start elementary OSit shows login screen but after logged in it just hanged nothing showing only wallpaper of login screen!!

No i am totally stuck i read somewhere that i should create a live CD on USB then bootup with USB and try to install it again then installer will show repair option! i tried it but repair option is not showing!

now i am very dishearted dont know how to get back my elementary OS or i will have to remove it and then reinstall it?? kindly if its possible to repair elementary OS. Thanks a lot!

I have installed elementary OS with Windows 7 dual boot!

2
  • Could you edit the question and addd output of apt-cache policy "pantheon*"
    – user.dz
    Dec 11, 2015 at 18:04
  • Google Chrome didn't break my freya
    – Suici Doga
    Feb 21, 2016 at 6:50

2 Answers 2

3

It seems like you unistalled parts of your desktop.

sudo apt-get install --reinstall elementary-desktop should do the trick.

BTW you can install chromium from the official repositories.

4
  • let me check thanks for ur reply u r only who replied have tried on stackoverflow and others thanksssssssss
    – maq
    Sep 24, 2015 at 10:11
  • 1
    it was not working so i did sudo apt-get install elementary-desktop then it says already in a newer version then i reboot still facing same problem now what should i do?
    – maq
    Sep 24, 2015 at 10:29
  • Please copy the entire command from the answer. You need to set the flag - - reinstall as well Sep 24, 2015 at 17:00
  • 1
    i did it but it did not work @Soundsphere kindly help
    – maq
    Sep 24, 2015 at 19:08
0

after fiddeling with drivers I lost the system settings object in Elemtary OS 5.1

This command resolved it. Thanks @Marc-Aurel Zent

sudo apt-get install --reinstall elementary-desktop

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .