1

My trackpad stopped working after updating form Juno to Hera, now I'm forced to use a mouse.

system info

from my xinput list the touchpas seems to be recognized:

Virtual core pointer                        id=2    [master pointer  (3)]
Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
USB OPTICAL MOUSE                       id=10   [slave  pointer  (2)]
Synaptics TM3108-002                        id=12   [slave  pointer  (2)]
Virtual core keyboard                       id=3    [master keyboard (2)]
Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
Power Button                                id=6    [slave  keyboard (3)]
Video Bus                                   id=7    [slave  keyboard (3)]
Power Button                                id=8    [slave  keyboard (3)]
Sleep Button                                id=9    [slave  keyboard (3)]
Integrated_Webcam_HD: Integrate             id=11   [slave  keyboard (3)]
Dell WMI hotkeys                            id=13   [slave  keyboard (3)]
AT Translated Set 2 keyboard                id=14   [slave  keyboard (3)]
DELL Wireless hotkeys                       id=15   [slave  keyboard (3)]

I tried installing synaptic drivers which seemed to be missing:

sudo apt-get install xserver-xorg-input-synaptics

but that didn't solve anything.

Any help would be much appreciated.

1

I see you do not have the new Kernel tried to update it

$ sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

I think that will solve your problem, someone else also had this problem here

elementaryos_about

  • I just followed the link instructions and the kernel update worked like a charm, thank you! – Tommaso Sebastianelli Dec 7 '19 at 15:00
  • You're welcome, it seems that with Hera it is necessary to update the kernel for the TouchPad to be functional. – LinkPhoenix Dec 7 '19 at 15:05
1

had exactly the same problem. The above-mentioned didn't help. For me I had to install the synaptic driver from the terminal. Even I didn't need the driver before, I need it now..

apt-get install xserver-xorg-input-synaptics xserver-xorg-input-synaptics-dev-hwe-16.04 xserver-xorg-core

Before xinput didn't show the device. After installig the driver xinput shows it SYNA3602:00 0911:5288 Touchpad

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.