0

I tried to install Elementary OS alongside windows 10.

I created a bootable disk with Rufus. I know that the disk works because I could manage to install it to my old thinkpad. But when I tried to install it on my Surface, I made a mistake and tried the option to create a partition and did something wrong.

When I tried to restart the pc did not open and gave me "something went seriously wrong, could not find mok" ( I am not sure if I am writing this correct the screen goes too quick). I took it to a repair guy, he installed the Windows 10 back again and windows works now. But my C/ drive shows only 99 something and there is a new D/ drive showing 18 something. I think this is because I tried to create a 20000 mb partition and this was wrong.

Now my surface won't boot from USB and gives me the same error. I can start windows. I don't know how to solve this problem and did not see anyone facing a similar problem. I am new to Linux and not really good with computers.

So I would be glad if someone could help me solve this problem.

5
  • the error is it Something has gone seriously wrong: import_mok_state() failed ? Commented Dec 7, 2019 at 12:47
  • Yes that's the error code ✌️
    – can erten
    Commented Dec 8, 2019 at 14:52
  • And what is 8 something and 99 something ? I think the person who reinstalled Windows 10 used the largest partition. And what is the Surface model where you want to install elementary OS? In addition, a bootable USB stick can work on one computer but not on another, because one supports the UEFI the other no and for other raisson Commented Dec 8, 2019 at 14:59
  • Thank you for your answer. Actually I solved the problem by going to the EFI folder of the bootable disk and change the boot x64 to mmx.efi and the problem was solved ✌️
    – can erten
    Commented Dec 10, 2019 at 10:18
  • Maybe you can Aswer your question by yourself with all your proceess, maybe that help other peoples Commented Dec 10, 2019 at 11:42

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.