1

'Try Elementary' works fine from bootable USB. However, after I install and boot I get a black screen after the splash screen.

I read about editing a line at bootup to state nomodeset, but I'm still getting the black screen.

I have an Nvidia-340, which may be the culprit. Anyone with more experience got a handle on this? I'm on a 2010 MacBook Pro.

I have tried reinstalling Hera three times.

  • Does opening tty1 work? (Dont know the Mac combo but on normal keyboards it's Ctrl + alt +f1) – rasmus91 Dec 7 '19 at 12:13
  • Fn + ctrl + option + F1. Can't open tty1 after it goes to black screen. I tried opening in recovery mode (which has the nomodeset boot option) and the results are the same. Is it possible to update video drivers from Grub? – Jason Diggs Dec 7 '19 at 13:43
  • Did you install while connected to the internet and allow 3rd party software? – duality Dec 11 '19 at 6:21
  • @duality for some reason, I could find and connect to the network before I began installation, but once I got to the screen with the checkboxes to connect to the internet the box was greyed out. I was able to click the allow 3rd party box. I'm unsure if it successfully downloaded the drivers. I've tried multiple installations and they've all had the same result. – Jason Diggs Dec 12 '19 at 12:22
1

I set nouveau.modeset=0 before and after install. If your laptop is still running while black screen, try connect a second monitor and see.

  • I tried both your suggestions. Second monitor didn't do anything. When I boot from bootable USB, second screen works. Booting from kernal doesn't show anything. I tried nouveau.modeset=0 as a boot option, but the results were the same. – Jason Diggs Dec 7 '19 at 14:06
  • So you mean primary screen is working but secondary doesn't? Have you try to install nvidia graphic driver for it? And go check display option see if the second screen are shown. – Vui Dec 17 '19 at 4:52
0

when booting from usb, select try before installing, then make sure you are online before beginning the installation.

I have had this problem before where it would only work if I was downloading and installing updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.