1

I've installed two Flatpak apps with sideload, and they never got icons and I cannot start them. What should I do? It was Spotify and Discord. Is this general limitation of elementary os?

Edit: The apps worked fine until I closed them

2

This is probably a bug that will be fixed soon. In the meantime you can launch Flatpak applications from the terminal. First execute

flatpak list

to get the list of you applications. Then run your chosen application (ie. org.example.app) by

flatpak run org.example.app

If you want to add the application to your application menu by hand, you need to find its .desktop file and copy it to ~/.local/share/applications:

cd ~/.local/share/flatpak/app
cd org.example.app
cd current/active/files/share/applications/
cp -a . ~/.local/share/applications

Icons should appear in the Application Menu immediately.

  • 3
    Since flatpaks are installed on a per-user basis, it would make more sense to copy the .desktop file to the ~/.local/share/applications folder, instead of the /usr/share/applications. No broken icon for the other users this way. – Vlad Pop Dec 7 '19 at 1:30
  • @VladPop Thanks, I edited the answer accordingly. – m93a Dec 7 '19 at 9:51
  • Thanks for the help. It worked great when I found the right .desktop file! – Gustav Ramestad Dec 7 '19 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.