1

I'm using Freya for developing web apps in Ruby on Rails with MySQL and PostgreSQL.

The problem is when I install the MySQL Workbench: when I try to perform a query the result is a blank grid.

I'm using Emma for querying (because the console is useful for basic queries but not for complex work)

  • I am having the same problem, I've tried various versions of MySQL Workbench, but none is working properly. – user2523 Sep 24 '15 at 17:36
  • I've tried many solutions but they have not worked. I'm a software developer so this software is important when i have to work with big databases in my daily work. If there is no solution i will have to migrate to another distro. – Maximiliano García Sep 24 '15 at 17:44
  • Please post your solution as an answer to your own question (and accept it) instead of adding the solution to the question itself. – r3bl Oct 15 '15 at 1:40
4

After some many tries, i have make it work by doing this:

I'm using Elementary OS Freya 0.3.1

Linux 3.19.0-30-generic #34~14.04.1-Ubuntu SMP Fri Oct 2 22:09:39 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

  1. Get the source from for 6.3.4 from http://dev.mysql.com/downloads/file.php?id=457803. THIS IS VERY IMPORTANT BECAUSE WITH OTHER VERSIONS IT DOES NOT WORK.
  2. Navigate to the directory you downloaded it to.
  3. tar xvf mysql-workbench-community-6.3.4-src.tar.gz
  4. cd mysql-workbench-community-6.3.4-src
  5. wget -O patch-glib.diff http://bugs.mysql.com/file.php?id=21874&bug_id=74147
  6. patch -p0 < patch-glib.diff
  7. sudo apt-get build-dep mysql-workbench
  8. sudo apt-get install libgdal-dev
  9. cd build
  10. cmake .. -DBUILD_CONFIG=mysql_release
  11. make
  12. sudo make install
  • Please make sure to mark this answer as having solved the problem :) – Daniel Foré Dec 3 '15 at 0:44
3

I had a similar problem. Please try to install the latest version from the official website: http://dev.mysql.com/get/Downloads/MySQLGUITools/mysql-workbench-community-6.3.5-1ubu1404-amd64.deb

  • Hi ounos, the bug still persist in that version. Any other solution? I've tried to compile it from source applying a "patch" but i have no results. – Maximiliano García Sep 24 '15 at 17:08
  • This does not work for me either.. However Maximiliano's answer helped me out.. – dhojgaard Oct 15 '15 at 7:06
  • Dependency is not satisfiable: libctemplate2 – daGo Sep 21 '17 at 11:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.