2

My issue is identical to this one, and it did solve my issue when I changed the logo from .png to .ico in .desktop. However, a restart/log-out session would render the solution void. As you can see from my screenshot below, I have the image extension as .ico, my StartupWMClass is also correct, but on the plank, there is still a Pocket Casts icon and a active grey gear icon. The two should merge.

If I edit the image in the .desktop file again, it became normal again. But I would have to do it every single time I log-out or restarts. It would be nice to have a permanent solution. The issue has been persistent since 5.0 months ago, I have tried different Pocket Casts linux apps and they all have this issue. I have not encounter this issue in any other app as of yet (I didn't install many).

I have Pocket Casts pinned, but it's the same if I unpinned and start from the application menu.

Thank you for any help

screenshot

0

I had the similar issue while setting up the AVD...

Here is my AVD.desktop file's current contents:

[Desktop Entry]
Version=1.0
Type=Application
Name=Android Virtual Device
Icon=/home/joe/.icons/AVD.png
Exec=/home/joe/Android/Sdk/emulator/./emulator @Q
Comment=Q @ Pixel_2
Categories=Development;
Terminal=false
StartupNotify=true;
#StartupWMClass=eOS

See the last line #StartupWMClass=eOS...? Try out the following:

  • Run xprop WM_CLASS in the terminal and click on Pocket Casts and cross-check the same.
  • Try Commenting the StartupWMClass= line.

Tip: you can reduce / truncate the Comment= section & uncomment the #Icon=pocket-casts while commenting the other #Icon=...

PS: I had to tweak here and there, checking out different combinations till I got it right.

Oh and one more thing make a copy of the .desktop file in /home/<user>/.local/share/applications/ and make the edits there. And this is important each time you make a change to the .desktop file:

Re-add it to your dock: (*credits @Cassidy James Blaede)

  • Remove any existing Chrome launcher from your dock by secondary/right-clicking it and unchecking Keep in Dock, or simply drag the icon off of the dock.
  • Open the app launcher (Applications) and drag the Chrome icon to your dock, or secondary/right-click it and select Add to Dock.
| improve this answer | |
  • 1
    Wow, thank you, I think you solved this. I have googled this before posting the question and thus have checked the consistency with "xprop WM_CLASS", but I never place a .desktop file in /home/<user>/.local/share/applications/. I just did and restarted ... the icons merged!! I hope it's fine from now on. Thank you. – SaltedFish Jan 10 at 9:41
  • Glad to hear that! Please upvote and mark it as answer if it worked for you. – joe733 Jan 10 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.