0

I'm using HP Probook G6 with Intel UHD 620 and I can't install Intel Graphics. I already tried with intel-graphics-tool, but I got error: enter image description here

And this is the output: https://pastebin.com/E0ZmMxiG

PS: I have elementary OS 5.0 Juno

New contributor
Davide Conte is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

Whenever dealing with drivers, you first need to remember that elementary os 5.0 is based on Ubuntu 18.04. With this in mind, you might notice that the repository https://download.01.org/gfx/ubuntu/, described in your screenshot, does not contain anything usable above Ubuntu 17.10. You should also know that elementary OS 5.0 already includes the appropriate MESA Intel drivers.

Running the command glxinfo | grep "OpenGL should output something like this:

OpenGL version string: 3.0 Mesa 19.0.8

If, like me, you encountered some issues running some games using the intel graphics adapter, you might benefit from installing the Mesa Vulkan packages:

sudo apt install mesa-vulkan-drivers vulkan-utils vulkan-tools

That being said, if you really need the latest drivers, you could try using the oibaf drivers ppa:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo add-get upgrade

After the upgrade completes, running glxinfo | grep "OpenGL version" again should output the following:

OpenGL version string: 3.0 Mesa 20.0.0-devel (git-3e21e17 2019-12-02 bionic-oibaf-ppa)

EDIT: if, during the update process, you encounter some ppa errors, you might need to do some cleanup first (maybe you added some obsolete repository?). Just run the following command, replacing name-of-the-repository with the name of the one you have to remove:

sudo add-apt-repository --remove ppa:name-of-the-repository
sudo apt update

For example, to remove the one from your screenshot:

sudo add-apt-repository --remove ppa:ubuntu-x-swat/intel-graphics-updates
sudo apt update
  • Unable to install vulkan-tools davide@davide-hp:~/Scaricati$ sudo apt-get install vulkan-tools Lettura elenco dei pacchetti... Fatto Generazione albero delle dipendenze Lettura informazioni sullo stato... Fatto E: Impossibile trovare il pacchetto vulkan-tools davide@davide-hp:~/Scaricati$ Output of glxinfo | grep "OpenGL version" : OpenGL version string: 3.0 Mesa 19.1.2 - padoka PPA – Davide Conte 2 days ago
  • vulkan-tools is not essential, you can try running the command without it. – Vlad Pop 2 days ago
  • Also, if you add the oibaf ppa, make sure to remove the padoka ppa first. – Vlad Pop 2 days ago
  • After removing padoka ppa I tried to do: sudo apt install mesa-vulkan-drivers vulkan-utils, but I already have last versions. – Davide Conte 2 days ago
  • Update: I managed to update Open GL version. Now output of glxinfo | grep "OpenGL version" is: OpenGL version string: 3.0 Mesa 20.0.0-devel (git-dde7340 2019-12-03 bionic-oibaf-ppa) But the issue is that system doesn't recognize model of my integrated graphics card – Davide Conte 2 days ago

Your Answer

Davide Conte is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.