2

I use OpenOffice, but got curious why so many Linux users and distributions are more into LibreOffice, so I downloaded it to check it out. When I tried to install it (a while back) I got an error message that said some conflict with files also used by Open Office was encountered. Ever since I can't install, remove, update or upgrade anything. I have tried the solutions suggested here, here and here but no solution and things keep me running in circles. Here's what I get when I tried autoremove, purge and autoclean:autoremove, purge and autoclean And when I ran the fix-broken install I got this: fix-broken installcont. fix-broken

And apt-get -f install: apt-get -f installcont. fix-broken

And trying to simply remove it: back to square 1

So I'm back to square one. Can't re-install or remove it, and can't ignore it either because it prevents me from installing or removing other stuff and even from updating the system (there are already 50 system components waiting in line in the AppCenter to be updated).

Any help is welcome. Thanks.

EDIT:

I downloaded OpenOffice from their official site short after I installed elementary, it never gave me any problem, and still works fine. It's the LibreOffice that's causing me all this trouble. I downloaded it from their site too (more than one month after OpenOffice, but I didn't install it immediately, and by the time I did -- and I don't recall this part so clearly -- I think I had learned already that it's in the repository and installed from there (or maybe I learned that short after installing the download version, I don't know anymore for sure). Anyway, the file I downloaded is still in the downloads directory and is called LibreOffice_6.3.3_Linux_x86-64_deb.tar.gz

UPDATE: As Bo rislav suggested, I tried using aptitude instead of apt. Here is what I got: aptitude -f install

2

It looks like the version of Libre office you try to install cannot work together with the version of Open Office you have. Try to boot into the recovery mode and fix broken packages from there. To achieve this, choose Advanced options for Elementary OS from the grub bootmenu screen, then Recovery mode. Connect to the network from there first, and after that choose Fix broken packages

There is something you should know - elementaryOS Juno it is based on Ubuntu 18.04 so most of the applications and solutions for Ubuntu 18.04 works also for elementary I suggest you to try this one - http://www.iasptk.com/ubuntu-fix-broken-package-best-solution/

or this one also: http://ubuntuhandbook.org/index.php/2015/01/fix-broken-packages-in-ubuntu/

  • I can't remove anything, it always bring me back to the results shown on the screenshots. autoremove, update and upgrade, all tried and none can be done anymore. – Joy Nov 30 '19 at 2:03
  • I don't know how you intalled open office, in order to give you the correct command, but if you use aptitude instead of apt you will have more control. For example try with sudo aptitude -f install. Then you will have some solution options and you can choose from these options. More info debian.org/doc/manuals/aptitude/rn01re01.en.html – Bo rislav Nov 30 '19 at 9:49
  • I tried and got this: ~$ sudo aptitude -f install [sudo] password for master: sudo: aptitude: command not found – Joy Nov 30 '19 at 13:30
  • sudo apt install aptitude ? – Bo rislav Nov 30 '19 at 14:21
  • 1
    Yes! This time it worked! :D I followed the instructions on iasptk.com/ubuntu-fix-broken-package-best-solution and removed the packages that were always named on the error messages (see screenshots) and after that the autoremove worked and took care of the rest of the libre-office and now everything works fine again. THANK YOU SO MUCH!!! It was a great help. – Joy Dec 1 '19 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.