3

I'm using firefox from this ppa:

https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next

Just today I got Firefox 42 beta, which is the first version linked to GTK3 instead of GTK2. The problem is the Window-Titlebar of the browser is totally misplaced: it's located in the same height as the adressbar of fiefox, slightly shifted to the right, making firefox unusable. A fresh firefox userprofile did not solve the problems. What should i do else than downgrading ?

Screenshot

closed as off-topic by Rafael, elmato, Daniel Foré, Lewis Goddard Sep 24 '15 at 21:08

  • This question does not appear to be about elementary OS, within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • You shoud report this issue to the firefox team... – Rafael Sep 23 '15 at 9:37
  • 3
    I'm voting to close this question as off-topic because it's clearly a (beta) firefox bug. – Rafael Sep 23 '15 at 9:38
  • 1
    I am curious why this question is considered to be not "within the scope". It is on ElementaryOS that the issue is encountered and the "workaround" provided allows to use an application on the system. Providing help on this particular question allows more users to try recent versions of Firefox and , thus, creates a larger base for Mozilla itself (and for EOS) - how is the new version supposed to be tested if no one is using it? If I'm not mistaken ElementaryOS is at version 0.3.1 so it still has some way to go before being considered mature. In my view any extra help should be welcome ... – SoftExpert Sep 24 '15 at 22:16
3

The solution is to install gtk3-nocsd package and to preload the small library provided by it by adding something like:

env LD_PRELOAD=/usr/lib/gtk3-nocsd/gtk3-nocsd.so 

in front of the command line launching your firefox.

The package is found in this repository.

More details here.

My own configuration for Firefox looks like this:

My Firefox command line

Edited A quicker way, without installing a package is to pass in the command line the option GTK_CSD=0 which is supposed to have the same effect (thanks to @augenleet I found the information in this Mozilla ticket). However, the "white text" issue still remains, though.

  • This isn't a solution, it's a workaround – Rafael Sep 23 '15 at 11:51
  • I would not argue for semantics. The man wanted to use his version of Firefox and now he can. As of why GTK client side decorations are not supported by Firefox or why they are breaking applications it's way beyond my daily life. I want to use elementaryOS as good as I can with the most recent applications available so I will go for a workaround or a patch or whatever serves my purpose. – SoftExpert Sep 23 '15 at 12:01
  • Nice trick to deactivate Client-Side Decorations. I tweaked the firefox wrapper in /usr/bin/firefox instead of the Launcher. Everything ist now placed as it should be, big progress :) Now I do have white fonts on white background in URL and Searchbar, even in some searchbars on some websites, but that's a different problem I'm going to research now – Wilken Haase Sep 23 '15 at 12:58
  • For everyone researching the same issues: White fonts on white background just happen on elementary GTK+ Theme. – Wilken Haase Sep 23 '15 at 13:06
  • 1
    I resolved this by installing Adwaita Theme (gnome-themes package) and adding another Environment Variable in my firefox launcher analog to the previous Hack: GTK_THEME=Adwaita. Solved :) – Wilken Haase Sep 23 '15 at 13:12
1

This bug is currently tracked here: https://bugzilla.mozilla.org/show_bug.cgi?id=1195002

Until it is fixed, you can use the following workaround. Simply start Firefox in the terminal with "GTK_CSD=0" ahead:

GTK_CSD=0 firefox

Not the answer you're looking for? Browse other questions tagged or ask your own question.