1

I would like to change the login screen keyboard to dvorak-fr but I can't find a way and the keyboard for login is in qwerty.

The keyboard indicator in Greeter say "No other layout available" and tty1 is in dvorak-fr as expected (as well as my session once I am logged).

1

The following solution works fine for me:

  • First open Language & region and add required language and layout.

  • Now open terminal and run:

    sudo dpkg-reconfigure keyboard-configuration
    

    Then it asks to select the following options:

    1. Keyboard model: Press Enter

    2. Country of origin for the keyboard: Select French and press Enter

      Imgur

    3. Keyboard layout: Select French - French (dvorak) and press Enter

      Imgur

    From now press Enter and continue for remaining options till end.

  • Now reboot the system.

  • 1
    If you have a mac, still press enter for the keyboard. It's doesn't work if you choose macbook/macbook-pro. – Olivier Lasne Jan 9 '16 at 12:43
0

This is what solved the problem for me. Goto System Settings -> Language & Region

The window would probably say something like language not properly installed. CClick on it and let it install. That's about it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.