Last night, I update my EOS by using sudo apt-get upgrade. After that, my boot time is very very slow. Usually take 5 second, now ~1 minutes (I using SSD). In terminal, I run systemd-analyze blame and this is the result:

         52.435s lvm2-monitor.service
          6.056s NetworkManager-wait-online.service
           646ms snapd.service
           519ms dev-sdb6.device
           430ms pantheon-parental-controls.service
           399ms systemd-logind.service
           346ms dev-disk-by\x2duuid-b0250d61\x2d5041\x2d478b\x2daf87\x2d85a390dcef9c.swap
           327ms snapd.seeded.service
           287ms lightdm.service
           287ms plymouth-quit-wait.service
           216ms systemd-resolved.service
           211ms systemd-journal-flush.service
           192ms NetworkManager.service
           171ms systemd-timesyncd.service
           143ms upower.service
           134ms networkd-dispatcher.service
           121ms udisks2.service
           117ms systemd-udevd.service

Thats lvm2 is crazy, how to fix this? Thanks

1 Answer 1


If you're not using LVM, you can try masking the service:

sudo systemctl disable lvm2-monitor.service
sudo systemctl mask lvm2-monitor.service

To determine whether you use LVM partitions, run:

sudo lvdisplay --verbose

To undo the disable/mask commands, run:

sudo systemctl unmask lvm2-monitor.service
sudo systemctl enable lvm2-monitor.service

OFF TOPIC: If you do not need NetworkManager-wait-online.service, you can disable and mask it as well. Get those precious seconds back!

  • I run that command, now when I check in systemd-analyze blame, lvm2 is not annoying anymore, but another service take more time. 4.142s udisks2.service and 1.178s dev-sdb6.device Nov 20, 2019 at 2:25
  • When I run systemd-analyze command, this is the result Startup finished in 43.088s (kernel) + 5.708s (userspace) = 48.796s graphical.target reached after 5.703s in userspace Nov 20, 2019 at 2:27
  • Looks like it's waiting on a disk drive. Let's dig in deeper then: please edit your question and add the output of the following commands: lsblk -f, cat /etc/fstab and sudo lvdisplay --verbose.
    – Vlad
    Nov 20, 2019 at 7:38
  • Thanks very much, with your explanation, I know that my SD card is attached to my laptop, and I don't know why my SD card is little bit broken. I know that issue when I run sudo lvdisplay --verbose. Now my EOS back to normal :) Nov 21, 2019 at 14:07
  • Glad I could help! And thank you for letting us know which command helped.
    – Vlad
    Nov 21, 2019 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.