1

I'm having some trouble with one of my network adapters being extremely slow. I've bought another adapter, got that plugged in and everything was working perfectly. But now the old adapter keeps stealing all the limelight, connecting to my wifi and being a general pain. Is there a way for me to disable a specific wifi adapter?

 *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 0c
       serial: 1c:83:41:00:6d:10
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:18 ioport:d000(size=256) memory:f7200000-f7200fff memory:f2100000-f2103fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlp4s0
       version: 00
       serial: 34:68:95:a3:01:71
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-70-generic firmware=N/A ip=192.168.0.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:c000(size=256) memory:f7100000-f7103fff
  *-network
       description: Wireless interface
       physical id: 2
       bus info: usb@1:1.2
       logical name: wlx78d38d12ad2e
       serial: 78:d3:8d:12:ad:2e
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.15.0-70-generic firmware=0.36 ip=192.168.0.24 link=yes multicast=yes wireless=IEEE 802.11

The offending adapter is RTL8723BE PCIe Wireless Network Adapter.

Thanks in advance!

2

The first thing I would try, if you have a laptop, is to disable the integrated (and faulty) network adapter from the BIOS.

If the above solution is not applicable, try to temporarily disable the network interface, use it's logical name with ip:

sudo ip link set wlp4s0 down

If this works, to make the change permanent, you'll have to run this command at startup. So, create a new .service file:

sudo nano /etc/systemd/system/disable-wlp4s0.service

Paste the following contents:

[Unit]
Description=Disable Bad Wireless Device
After=sysinit.target
StartLimitIntervalSec=0

[Service]
Type=simple
Restart=no
RemainAfterExit=yes
User=root
ExecStart=/sbin/ip link set wlp4s0 down

[Install]
WantedBy=multi-user.target

Use Ctrl+O to save the file and Ctrl+X to exist nano editor. Next, enable the new service file, so that it runs at startup:

 sudo systemctl enable disable-wlp4s0

Other useful commands are:

sudo systemctl start disable-wlp4s0 to start the service

sudo systemctl stop disable-wlp4s0 to stop the service

sudo systemctl status disable-wlp4s0 to see details about the service

Another solution would be to change the priority of the network interfaces, instead of disabling one of them. The card with the smallest metric has the highest priority.

| improve this answer | |
1

Click on the network indicador and then click on Network settings (or the closest to this - I'm running eOS in pt_BR). It'll open the network settings screen. Each network device shows a toggle on the top-right. Flipping this toggle will enable/disable the device.

Network settings

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.