1

Everything I open will open in this cretain of a browser called Epiphany. Discord, Thunderbird, etc.. all Links open a new instance or tab in Epiphany. I do want to open everything only in Firefox. I can't be the only one. How to mitigate this issue?

4

Go to System Settings > Applications > Default Tab. There you can set your default web browser, email client, text editor etc.

enter image description here

1

In some instances, the program you want to define as default does not appear on its category menu drop-down in System Settings > Applications > Default tab

Another way is to right click on a file with an extension (for a web browser, that would be a .html file), and set the program to be used in Properties.

0

This can also be set directly from a terminal with the xdg-settings command. Just provide file name of the .desktop file for the browser, often available in /usr/share/applications or in ~/.local/share/flatpak/exports/share/applications/ if the browser was installed as a Flatpak. For instance, to set the default web browser to Firefox, assuming it's installed of course, just use the following command.

$ xdg-settings set default-web-browser firefox.desktop

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy