I'm primarily looking for guidance on how to continue debugging this problem if no answer is readily available.

I am on the latest Dell XPS 13 developer edition with the 10th generation Intel processor. I am attempting to boot an Elementary OS Juno live USB. After selecting the USB as a boot device I get to the grub prompt and select "Try elementary is before installing" this then hangs at a blank screen (no cursor so is not similar to the nomodeset problems of yore).

The computer does not advance past this screen. I have tried editting the boot entry to remove quiet and nosllash and set the gfx mode to text. All permutations have not had any effect. The same USB I'm booting from does boot instantly on my Thinkpad T480.

I am using UEFI boot with secure boot disabled. There is no BIOS or legacy boot option available on this system.

  • Have you solved your problem? your question is very interesting, especially that elementary OS on a Dell XPS is really perfect. Can it be that by updating the kernel with the new version Hera it will solve the problem? Commented Dec 9, 2019 at 23:25
  • I had the same problem, but nomdeset helped. Sigh, it was a cold shower for a person that wanted to test a live linux distro after 7 years. Like, boom, it's almost 2020, but you cannot flawlessly run newest linux on a usb stick without at least typing a single program command... For these kind of issues, I think I will forever be stuck in Windows (and, of course, due to lack of any Adobe support, sigh).
    – ivan
    Commented Dec 11, 2019 at 22:21

2 Answers 2


In my experience this kind of hang is due to a lack of GPU/video support. I'd say you need to boot into an un-accelerated 'safe' video mode and keep using it until you've run a full update (new kernel, new video drivers.)

Press 'e' on the try elementary os option and add 'nomodeset' (without brackets) to the portion that says 'splash quiet".

Install as usual and run a full update. Then remove the 'nomodeset' text from '/etc/default/grub' and run 'update-grub'.


The recent kernel update from Elementary OS 5.1 resolved this issue. I was able to install eOS much sooner by building my own daily ISO but have since re-installed with the latest ISO and it works with the new HWE stack.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.