2

Using an Asus router to share a USB Samsung printer. The Print Server uses LPR and some Queue name. I can get this to work easily in Windows and PCBSD (FreeBSD), but Elementary OS it just sits there not detecting anything. With the other OS's, I had options to select which protocols to use, but Elemenary has nothing but some search bar.

I tried searching but no results showed, except for Ubuntu and the screens look different... So here I am. Thank You in advance

3
  • Okay, after some searching, I found out Elementary OS and Ubuntu (and probably other FOSS OS's like FreeBSD) use CUPS! was able to do something when I entered localhost:631 into a web browser. Now a printer shows up in the printers section of system setting, but if I wanted to use the add printer option, it don't work!
    – ZarK
    Sep 22 '15 at 4:40
  • Please add this as an answer (not a comment) and mark your issue as resolved.
    – r3bl
    Sep 22 '15 at 18:43
  • Have you been able to resolve this as yet?
    – RolandiXor
    Oct 7 '15 at 19:52
1

Your user needs to be a member of the lpadmin group to have privileges to add a printer. That is the default setting. You can double check /etc/cups/cups-files.conf and look at the "SystemGroup" setting to confirm this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.