1

When trying to open the trash on Files app the trash doesn't open and gives a message saying that the server of that folder could not be found, as per the picture.

enter image description here

The address of the trash folder is trash:///.

1

Open Files and in the address bar try accessing ~/.local/share/Trash/files/ to see the contents of the Trash Folder. If this works, and you are able to see the contents, you can choose some files to undelete by selecting them, Ctrl+X to cut them, and them Ctrl+V in some other folder (by design, right clicking in the Trash folder displays a menu containing just a Paste entry).

The error should go away by emptying the trash folder by deleting the contents of ~/.local/share/Trash/

Another simpler way to empty it is by right-clicking the Trash link in the Files sidebar and selecting Empty Trash.

EDIT: looking closer at your screenshot, I see you have multiple devices, and a network share. It is worth having a look at .Trash folders on those devices, since Files will try to display their contents as well (to see the .Trash folders on those devices, right-click an empty area in Files and select Show hidden Files). I believe that mounting all your devices and shares, and then trying to access the Trash from the Files sidebar will work.

| improve this answer | |
  • Thanks, it appears that your solution works but I don't know if deleting the files under ~/.local/share/Trash/files/ really worked because of the network folder share was not available when I was trying to open the Trash and now it is (it is a folder shared only in my workspace). It might actually be an error when the network file share is not available, though it keeps being listed in the files app. I will test this behavior later in a more appropriate way. – Rafael Campos Nunes Nov 5 '19 at 16:41
  • Sometimes this happens to me also when I remove some usb drives, but after I close and reopen Files application everything is ok – Bo rislav Nov 5 '19 at 17:23
  • Glad to know I'm not the only one with this problem. By the way, deleting the files most probably solved the problem as It didn't occur again when the folder aforementioned was not mounted. – Rafael Campos Nunes Nov 6 '19 at 0:34
  • I suspect this is an issue with how the underlying virtual filesystem (gvfs) merges multiple trash folders, some on remote filesystems, rather than Files code itself (unless the time limit used is too short - how long before the trash view failure message shows?). – Jeremy Wootten Nov 8 '19 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.