0

So I've read up on the forum that this is a recurring problem, but this might give just a little more insight.

I installed elementary OS (latest version) on my laptop. The SSD was clean and formatted. When the installation was done, I rebooted and came onto the grub error.

I tried this solution, but it did not work for me. Comment 5 for bug 1492801

When i did do this, I got an error when i tabbed to look for a configfile. it stated:

  • hd0 hd1 hd2error: failure reading sector 0xe8adb0 from hd0 and then some more read errors from hd0 and hd2 (hd 1 is swap)

I'm looking for a fix and will update if i do find one.

0

1 Answer 1

0

Freya has a known UEFI bug. You can find details here.

Here is a sister thread that walks through the fix.

Please let me know if you need anything explained and I will try my best to expound on their solution.

4
  • Well, whenever i do the fix, i get read errors (as you can read in my question). So I am completly stuck at the grub.
    – Mrpopo666
    Sep 22, 2015 at 12:35
  • How old is the drive? Have you tried any disk scanners to see if the bad sectors are actually there? Also, I apologize for not recognizing that detail when i initially read your question. Any luck with other debian-based distros like Ubuntu or Mint?
    – josef
    Sep 22, 2015 at 18:35
  • Ubuntu is what i'm currently running. after multiple failures with multiple images of elementaryOS, i installed ubuntu to make sure it worked, and it hasn't failed yet. Also, Disk scanners tell me there is no problem with my SSD
    – Mrpopo666
    Sep 23, 2015 at 16:04
  • Is the SSD partitioned with a GPT table? What partition scheme did you use?
    – josef
    Sep 29, 2015 at 22:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.