0

new to Linux here.

I installed Elementary, and there is no option for Wi-Fi. I've tried several solutions on the internet, none of them worked.

My computer is Razer Blade 15 Advanced Model. GPU is NVIDIA GeForce RTX 2080 Max-Q. I've tried the following:

Installing NVIDIA Driver 430 and 440 manually, using this reference https://www.fosslinux.com/1462/how-to-install-nvidia-gpu-drivers-in-elementary-os.htm (although instead of sudo apt-get install nvidia-xxx, it was sudo apt-get install nvidia-drivers-xxx). This does get the NVIDIA 440 installed, but then wi-fi still does not work.

Installing drivers automatically, by the following command: sudo ubuntu-drivers autoinstall. But this gives me this error:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 nvidia-driver-440 : Depends: xserver-xorg-video-nvidia-440 (= 440.26-0ubuntu0~gpu18.04.2) but it is not going to be installed
                     Depends: libnvidia-cfg1-440 (= 440.26-0ubuntu0~gpu18.04.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've also tried installing the drivers through the App Centre. This also gets the drivers installed, but then nothing happens.

I have turned off secure boot from the BIOS as well.

Here is what happens when I do -lshw -C network

WARNING: you should run this program as super-user.
  *-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: memory:58300000-58303fff
  *-network
       description: Ethernet interface
       physical id: 1
       logical name: enx000ec64d2006
       serial: 00:0e:c6:4d:20:06
       size: 100Mbit/s
       capacity: 100Mbit/s
       capabilities: ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=asix driverversion=22-Dec-2011 duplex=full firmware=ASIX AX88772 USB 2.0 Ethernet ip=10.0.0.10 link=yes multicast=yes port=MII speed=100Mbit/s
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

This is my first Linux distro, so I'm sorry if I'm a bit slow. Please help, thank you very much!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.