I created a Bootable usb for elementary os using etcher however when I try to boot from it on my Lenovo thinkpad x1 carbon (gen 7) it gets stuck at a black screen after selecting try elementary OS without installing from the grub. I tried the same usb stick on another laptop and it was able to bootup properly. I have turned off secure boot on my lenovo x1 carbon. Also, I have previously installed Ubuntu and manjaro on the same machine successfully. I don't know why elementary OS is running into issues.

Update: Tried with 'nomodeset', tried different software like Rufus, UnetBootin and Etcher to create bootable.

  • If you get to the GRUB selection screen it is nothing wrong with the "boot-able" part of the USB, it's already past that stage when GRUB kicks in. Have you upgraded the BIOS lately? This sounds like some BIOS bug to me. May 11, 2021 at 22:13
  • I had the same error on Hera. I guess that there is an issue with the installer... It works like a charm in the new installer.
    – Kerek
    Sep 8, 2021 at 15:11

1 Answer 1


Can you try to boot using a parameter nomodeset. Select 'Try elementary os without installing' and press 'e' on you keyboard. Then edit the line containing quiet splash so it became quiet splash nomodeset --- and then Ctrl+x to boot with this parameter.

There is a similar question here, so this one is a duplicate. You should avoid that.

  • Tried nomodeset it doesn't work, failed with same result. I remember using nomodeset for Laptops with Nvidia GPUs. However, Lenovo thinkpad x1 c doesn't have one. Nov 10, 2019 at 1:09
  • I see a lot of people complain about that newer laptops cannot boot with elementary live usb.. I do not know if yours is a new one but nomodeset is not only for Nvidia graphic cards - the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes(low resolution) instead until X is loaded. >> askubuntu.com/a/716966/730454
    – Bo rislav
    Nov 10, 2019 at 1:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.