2

I tried to install elementary OS today on my tower but I ran into a problem. I installed a previous version of Juno without problems, but now I can't get the Installer to boot.

I downloaded the Installer and checked the checksum, it was correct. Then I flashed the USB with etcher and tried to boot it. During the reboot I selected the USB and tried all three option (try, install and OEM install) but I got the same result every time: The screens show a weird pattern and then goes blank. Then the fans of the graphic cars spins up to max for a moment before they slow down again and I'm stuck with a black screen.

I'm running the following hardware:

  • AMD fx8350
  • Asus Sabertooth 990fx
  • AMD RX 590

Thank you very much in advance for your answer

1

Same here, but I tried on the same hardware system like before the same elementary OS image on a USB stick. I think it is the same, because I tried to download the new one, but the torrent client verified that it is the same like an year ago. What I found is that if I try to boot with the same USB stick another computer, everything is ok.

The only way to start the current one was by using nomodeset parameter before I choose the 'try' option. To achieve this select 'Try elementary OS' and press the 'e' key on the keyboard, then add nomodeset after quiet splash so it became quiet splash nomodeset --- and press Ctrl+x to boot the system with this parameter. Good luck!

  • some information about nomodeset, quiet and splash - askubuntu.com/questions/716957/… – Bo rislav Oct 22 at 6:21
  • I tried your solution but sadly still got the same weird pattern and the blackscreen afterwards. I also tried the Installer on an old laptop, it worked normal. – Section-1337 Oct 23 at 15:15
  • Sorry, my mistake.. nomodeset has to be with lower case. Can you try like that? I edit my answer.. – Bo rislav Oct 23 at 16:05
  • Thank you for your answer, I tried it with lower case again and the live system boots but during boot i get a driver error for the GPU and the live System runs on low resolution. I will try an install tomorrow to see, if this or a driver will fix this last issue. – Section-1337 Oct 24 at 18:09
  • I tried the installation and the error continued. Sadly I wasn't able to install the ubuntu driver for my graphics card after installation so I can't run elementary at the moment. After the installation I did some testing with other linux distributions and discovered, that older kernel version don't support the RX 590 (for example OpenSuse with Kernel Version 4.12). Is there a way to upgrade the Kerne to a newer one because it seems to be finde on 5.X? – Section-1337 Oct 25 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.