1

I've been using elementaryOS on both my desktop and laptop computers for a few years now, and have never experienced any problems.

Recently I upgraded my desktop's graphics card from an old Radeon 7790 to a RX580. Upon starting elementaryOS everything was fine until I noticed the screen would get corrupt and the PC would lockup, not even capslock would respond. I tried reinstalling the system and switching to oibaf, but the problem would persist.

After my options ran out I decided to install Ubuntu, and never had a problem since, that was a few months ago.

This month I decided to give elementaryOS another try, and the problem still exists, however not as often as it would. Also, the computer recovered from one of the instances it had happened after blinking the screen a few times.

But it still happens randomly.

Also it has never happened on ubuntu or windows. This makes me think it's elementaryOS related.

Is there any diagnostics I can run to check this? Here's a picture of the corruption: enter image description here

  • Is HWE (hardware enablement stack) installed on your system? – a-tokarev Oct 17 '19 at 9:36
  • What Ubuntu version did you try? elementary runs over ubuntu 18.04 LTS so you should get the same hardware support. You don't need to add any PPA for the drivers, the amd drivers are inside the kernel already so just upgrading the kernel will be enough. – Maccer Oct 17 '19 at 9:39
  • How do I check for hwe? I tried ubuntu18.04. – RodrigoN Oct 17 '19 at 12:30
0

@RodrigoN, if your kernel version (which can be displayed in Terminal via uname -r command) is below 5.0.x, and your initial Ubuntu distro was 18.04 or 18.04.1, you don't have HWE installed. As stated here:

"The [HWE] stack consists of a newer Linux kernel [meaning, v5.0], X.org graphical server, and graphics drivers. These weren’t automatically installed on existing systems <...> If you installed Ubuntu 18.04 using the Ubuntu 18.04.2 installer, you will automatically get the Ubuntu 18.04.3 update featuring the new Linux kernel. If you installed Ubuntu 18.04 using Ubuntu 18.04.1 or the original Ubuntu 18.04, you won’t automatically get the new Linux kernel."

To install HWE on Ubuntu 18.04 desktop PC, execute:

sudo apt install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

  • Thanks. I have installed HWE and will report back after a period of testing. – RodrigoN Oct 21 '19 at 2:40
  • So far not a problem after tinstalling HWE. Thanks for the help! – RodrigoN Oct 28 '19 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.