0

I've just installed elementary OS 5 Juno, my problem is that after my notebook suspends it never wake's up or return from the suspending state, doesn't matter if is suspended because the lid was closed or because inactivity it never wake's up, the only i can do is power off the computer with power button and thats a problem, does anyone have the same problem or knows solution? My system is:

  • Lenovo ThinkPad A485
  • Ryzen 7 2700u pro
  • Graphics VEGA 10
  • RAM 16 GB
  • Swap file size 16 gb
  • Linux kernel 4.15
0

Well I've tried a lot of solutions that I found out there in another stack-overflow forums, but sadly it didn't work, but at the end I found a lead that takes me for one solution that work with my system. First I will share the things I've tried and don't work and finally I'll tell what indeed fixed my problem

What didn't work:

  1. I found that my notebook weren't really suspending because the "Caps Lock" key still powering on if i pressed in the keyboard, and the power light never started to blink as my notebook usually does when is suspended, that symptom make's me thought that my problem was related whit this issue: https://askubuntu.com/q/1029474/537536

Then i tried the diagnose and solution proposed by monty47 but it didn't take any effect in my system. Editing the grub line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash mem_sleep_default=deep"

  1. I read the following answer https://unix.stackexchange.com/a/500111 and i try it editing grub (again) with the options suggested adding nouveau.modeset=0 to the line that says GRUB_CMDLINE_LINUX="" But it didn't make any difference neither.

The lead:

  1. I start to notice a trend in many answers not accepted in the questions i was reading, compatibility issues with video drivers, many of them suggested video drivers update and kernel updates, so i firstly try to update my current open source drivers. I followed the instructions for install the latest open source amd drivers in the next guide: https://linuxconfig.org/how-to-install-the-latest-amd-radeon-drivers-on-ubuntu-18-04-bionic-beaver-linux

The installation was successful, but the problem was still there.

The real solution for my problem:

  1. Then i decided update my system kernel. In the following reddit post many people was talking about the kernels that best suit their builds whit AMD ryzen 7 2700u vega 10 (oh! the same build i have) https://www.reddit.com/r/Amd/comments/ahwu76/are_rysen_7_2700u_and_vega_10_well_supported_at/

Summary almost all answers were suggesting to use kernels 4.19 and 4.20, since 4.19 is a LTS release I though it was a good idea start trying it and then moving forward to 4.20, but it wasn't really necessary, when i installed the new kernel the suspending issues stopped, it was my solution. What i did in order to update my kernel:

  1. I made a backup of my system in case anything goes wrong, i strongly recommend backup your system even more if you are going to do something dangerous like update the kernel. I used Timeshift a wonderful and easy to use tool, the instructions for backing up and restoring are in this page:

  2. I installed ukuu and select the latest release of kernel 4.19 (at this moment 4.19.79-041979-generic) the instructions to do this can be found here:

Well that was my experience whit this issue, i recommend check if your problem is a problem of configuration or a compatibility problem and always make a back up of everything before applying any solution that may prevent you from starting your system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.