0

I have a mixed environment; Windows and Linux. Linux is made up of a number of distros and flavours; Vanilla Ubuntu server, ElementaryOS, Vanilla Arch and some network devices that run BusyBox (Ubiquity).

On my ElementaryOS PC, I am wirelessly connected. When I try to contact a local Ubuntu server, I am given my external IP address (both of these servers have an externally available FQDN DNS entry with the same name).

But, if I disconnect from the network and then reconnect, I have about 10 seconds where I can ping the local name and am presented with the INTERNAL IP address. After this ten seconds or so, any further pings return the external IP address.

This does not happen from any of the other Linux boxes... so, I have to assume that it is something to do with the services on this ElementaryOS PC.

I have added DNS entries to systemd/resolved.conf as advised elsewhere. I have added a defined entry for DNS in NetworkManager (which I do no want to do... I want to use the DHCP settings) amongst other things...

I am not looking for a work around, am looking for a fix. I am happy to change network managers if that can solve things.

The thing I don't get is what is the process that is changing the results- it works correctly for ten seconds then goes haywire...

Any thoughts gratefully received.

Gary

  • Internal and external names should be different, that's likely why you're getting conflicting information. – user162687 Oct 14 at 3:44
  • Disagree... If I have a service on a network that I want to be able to access from both inside and outside, I should be able to make a request to FQDN and receive the correct IP address whether I am inside or outside of the LAN. If inside the LAN and pointing to my internal nameservers, I can configure my name servers to serve the internal LAN address of the service. If I am external I should be able to rely on the details I have entered into my external name servers, thus giving me the external IP address. This system works for everything on my network, except ElementaryOS – Nubink Oct 15 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.