0

So trying to increasingly run my desktop with modern settings, I am installing flatpaks to replace .debs

I'm having some issues actually running them. This is an attempt at running the nextcloud client

$ flatpak run org.nextcloud.Nextcloud 
Invalid MIT-MAGIC-COOKIE-1 keyqt.qpa.xcb: could not connect to display :99.0
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

and this is trying to run the Midori browser:

$ flatpak run org.midori_browser.Midori 
Gtk-Message: 11:11:40.557: Failed to load module "pantheon-filechooser-module"
Invalid MIT-MAGIC-COOKIE-1 keyUnable to init server: Kunne ikke forbinde: Opkobling nægtet

(midori:2): Gtk-WARNING **: 11:11:40.560: cannot open display: :99.0

This seems to have something to do with X11 and displays, but after doing a bit of google-fu, I can't seem to find a solution.

Any hints?

  • What happens if you install xcb ? – Maccer Oct 8 at 14:53
  • @Maccer That makes absolutely no difference. I think for the nextcloud package XCB is a requirement that comes with the app. – user3801839 Oct 8 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.