I just read the September updates blog post and updated via App Center. I don't see anything added to Online Accounts; so, I'm assuming I still connect to the Nextcloud server through Files>Connect to server. When I do that, I still get the same behavior as I previously would which was, after entering the information, the configuration screen comes back and nothing connects.

3 Answers 3


While nothing to offer in regards to the libcloudproviders update to files (because it makes no difference here, on my system, at all)

It sounds like you would like to connect to nextcloud via Webdav. Let me help you do that.

Open files, and click -> Connect to Server

choose whichever fits (Https if you have set up nextcloud with SSL or HTTP if not)

in the serverfield input: url or ip address as appropriate. no protocol spec. e.g.:




then under dir/folder, input:


then input your username/password. If you set it up with a selfsigned certificate, you will be prompted to accept an untrusted certificate. Then it should be connected. but please notice: This webdav connection will not be seen by files as anything related to nextcloud, as that is abstracted away when using something like webdav (and that is really what such protocols are for)


You can create the folder /usr/share/cloud-providers, and then put the file com.nextcloudgmbh.Nextcloud.ini there. You can get the file from the Archlinux package here:


You will also need the Nextcloud desktop client installed, which you can install from the Nextcloud ppa. Configure and set the Nextcloud client to start at login. Log out and login again, and you should see the Nextcloud option in Files.


in addition to rasmus91 solution

  • works fine on eOS 5.1.7 Hera and Nextcloud 20.0.1

  • if NC is installed on a path like: yourdomain.com/nextcloud

    • add the path before remote.php nextcloud/remote.php/webdav/

I needed to figure that out for 10min..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.