Hi there recently I switch from windows to Elementary OS Juno, my WiFi does not work, I tried many ways, nothing worked. So I bought 2 wifi routers, but both say "Wireless is Disabled". I would appreciate your help, I'm a noob. I want at least one of those work, I'm currently using USB tethering.enter image description here

details: HP Elitebook 8440P Core i5

Wifi card: Intel Corporation 82577LM Gigabit Network Connection.

1st Wifi router: TPLINK TL-WN422G.

2nd Wifi router: 802.11 n wlan.


Did you install the proper driver for your wifi adaptor? Maybe you can find some information in ubuntu forum like this, https://askubuntu.com/questions/512727/how-to-install-driver-for-tp-link-tl-wn722n-on-ubuntu-14-04


Looking at your laptop from the spec sheet I found on HP's site, it looks like you have an Intel powered wired internet connection card, but your WiFi card is made by Broadcom. It's pretty common for boards to have network adapters from different manufactures but since the WiFi one is what's acting up, you likely need a Broadcom specific driver.

I found a very extensive guide as the top answer to this AskUbuntu question with step by step instructions on setting up Broadcom drivers within Ubuntu and this should work for Elementary. This does look to take a bit of reading and paying attention, but it looks like it should help out!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.