I used rufus to burn a usb to make it into a bootable usb for elementary OS 5.0 Juno with which I was hoping to be able to dual boot elementary OS 5.0 Juno with my already existing windows 10. However, when I boot into the usb and select Install elementary OS it show a screen where it shows some sort of error, something about "couldn't read" for like 2 seconds and goes away then nothing happens. I tried the other options as well but nothing worked. Do you know what I should do?

  • That destroyed my USB – Jag Tanna 7 Oct 3 '19 at 18:16

I used usb-startup-creator available in xubuntu to create an install-usb for elementary os this week. Worked perfectly!

Or maybe check the bios/uefi/secureboot settings of the laptop. Sometimes laptops are protected to prevent installing other os's than windows...


check the integrity of the ISO you downloaded, it could be that your elementary ISO is corrupted or maybe your USB is faulty

  • I have tried that – Jag Tanna 7 Oct 3 '19 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.