0

After the most recent system update, I noticed the problem both on Loki and Juno as well as Juno beta that I both still have installed on my machine.

In Juno, there's also some display issues, flashing with patterns, from time to time.

The mouse cursor displays stable in pointer mode as a vertical dashed line of white dots with a shadow.

A similar issue is described here, even including a snapshot

Update: upon rebooting, the whole screen was tiled to the left 3/4 // 1/4 on Juno & Juno beta, and the system is not accessible anymore in that appearance.

Update 2: upon resume from suspend, if no BSD, the systems resumes with the display in order, but that situation doesn't last for long.

  • It seems that there's a known issue with the main graphics adapter on my system which seems to have failed, as I going in recovery mode switches to the alternative Intel adapter since the AMD Radeon HD 6750M doesn't work properly anymore, and just checked logging in MacOS recovery mode to reinstall ReFind, the screen is blurred with horizontal lines; switched to recovery mode and there display seems stable. – Lurch Sep 20 '19 at 7:34
0

The temporary answer that I found to the problem (a known issue to the model), is to start elementary in advanced options, and go into recovery mode. Due to the fact this 2011 MBP model features 2 video adapters (thus now on the Intel one), the settings work just fine, however there's no way to either resume from suspend or hibernate on this mode, neither on Ubuntu 19.04 that I installed as well (it was also an easy answer to install grub2, reinstall ReFind and have access to the advanced boot options), just to test the distro. Whatever I tried, I could not resume from suspend or hibernate. However, apart from that, the system is working just fine. Though there's a more elegant answer, than the before temporary one that works, only if you have access to grub menus.

Here's the walkthrough: (as of Opiniated Logic, a more elegant answer):

Disable the AMD graphics card permanently:

Once you reboot you’ll need to press e in the grub menu line you are expected to boot from.

Look for the line:

set gfxpayload=keep

Once you’ve found it, type the following lines underneath to disable the AMD graphics card:

outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0

Next find the kernel line and after “quiet splash” , add the following:

i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0

After checking to make sure that we’re mistake-free press F10 (likely Fn + F10) on the Macbook. This should allow us to boot with the integrated Intel graphics card.

This will load your new Ubuntu Linux system with Intel graphics.

Now once booted successfully into the system with working graphics, we just need to set things up so you don’t need to do that "ever" again. Start a Terminal and run the following command to edit the necessary file:

sudo gedit /etc/default/grub

This will ask you for your user account password to get admin privileges. Enter it and when the file opens search for the line:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash“

and change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0"

Once this change is made, check for errors then save and exit.

Next we’ll run another command in the Terminal:

sudo gedit /etc/grub.d/10_linux

Again, enter your password if asked and when the file opens find the line

echo "  insmod gzio" | sed "s/^/$submenu_indentation/"

And place the following immediately before this line:

echo "  outb 0x728 1" | sed "s/^/$submenu_indentation/"
echo "  outb 0x710 2" | sed "s/^/$submenu_indentation/"
echo "  outb 0x740 2" | sed "s/^/$submenu_indentation/"
echo "  outb 0x750 0" | sed "s/^/$submenu_indentation/"

Check to make sure that everything is correct and save, then exit gedit once more.

Finally run:

sudo update-grub

This will update the boot loader settings we just changed and make them stick. The next time we reboot we won’t have to type out all those obnoxious commands to disable and enable things.

Personal note: you will have to keep this info handy in case there's a kernel or system update that erases your updated grub's config: in that case, you will have to update grub again making sure the two files are updated again and grub updated consequently.

| improve this answer | |
  • Note the instructions in the following [link] (orville.thebennettproject.com/articles/…) work perfectly editing Grub at startup with e, but I don't seem to succeed reproducing the instructions while editing /etc/default/grub in order to make the changes permanent, as both files are not the same. – Lurch Sep 22 '19 at 12:58
  • The grub configuration had to be updated by ReFind that I reinstalled through a boot in recovery mode in my MacOS recovery partition and now the arguments are passed on successfully and the problem circumvented. It was just a matter of updating the grub info in ReFind. – Lurch Sep 27 '19 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.