0

I've just completed a fresh install of 5.0 from the ISO on the website, but am unable to update/upgrade packages.

Trying to run sudo apt update, or install anything from the AppCentre both result in the following error:

E: The repository 'http://packages.elementary.io/appcenter juno Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default.

This seems to be the same issue as in this page: Juno sources - no release file

I'm about to try following those instructions to resolve it, but thought I'd post an update that this is still an issue. Unable to install software on a fresh install seems like a rather critical bug to fix from a user experience point of view...

1

After executing sudo apt update I see this line in terminal's output:

http://packages.elementary.io/appcenter bionic InRelease

instead of

http://packages.elementary.io/appcenter juno Release

As my system doesn't have any issues with updates, you could try to swap the lines and see if it helps. (If it doesn't, just revert the process and try other solutions.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.