I've downloaded Intellij ultimate version and I am trying to open idea.sh but it tells me this:

"JDK Required: 'tools.jar' seems to be not in IDEA classpath. Please ensure JAVA_HOME points to JDK rather than JRE."

I don't know what to do, can anybody help? I've searched in Google but couldn't find anything.

all I know is that I have jdk because when I use java -version it tells me something, but I can't locate the path or somethings wrong

echo $JAVA_HOME returns


this happened after I've installed java-7-openjdk before that I had java-9-oracle and I thought it was jdk but there were still problems

I've tried without sudo and everythings seems fine.

1 Answer 1


Seems like you don't have de JDK, only the JRE. Try run this:

sudo apt-get install openjdk-7-jdk

The java you see on java -version is installed via the openjdk-*-jre package and it's able to run java applications. But to develop java (and run most of java IDEs) you need the openjdk-*-jdk packages.

If you're still having trouble, try this links:



  • i have that and echo $JAVA_HOME returns: /usr/lib/jvm/java-7-openjdk-amd64/ Sep 20, 2015 at 11:20
  • That's strange. I have a recently installed Freya. I just installed the openjdk-7-jdk and set the JAVA_HOME to the same folder as yours. Downloaded the IDEA Community Edition 14 and all worked fine. Try apt-get purge the openjdk packages and reinstall them. Also, see if your previous installation from oracle have been completed removed as it may have conflicting configs with openjdk. Sep 21, 2015 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.