17

I am a vim user and I need to use CTRL+V from time to time. Currently it pastes clipboard contents into terminal. In Luna, CTRL+SHIFT+V was used for pasting. How can I change the behavior of the terminal?

I don't want to remap the CTRL+V action.

Thanks in advance, Magnus.

  • This is only partially related, but maybe still worth mentioning: SHIFT+INS does the same thing. Something that I found very useful on MS DOS, if I remember correctly... – Paul Sep 19 '15 at 17:23
14

The ability to paste clipboard contents into the terminal using the standard Ctrl + V shortcut is called "natural-copy-paste" and you can disable it in the dconf settings.

If you haven't already done so, install dconf editor using this command:

sudo apt-get install dconf-tools

Open dconf editor and navigate to org > pantheon > terminal > settings. Once you're there, you can untick the option.

enter image description here

Now pasting into the terminal using Ctrl + V no longer works, and the former default shortcut (Ctrl + Shift + V) is restored.

  • 4
    For elementary OS 5.0 Juno the correct path is: io.elementary.terminal.setttings – epergo Sep 15 '18 at 10:04
7

If you prefer to do things in the terminal, simply run

gsettings set org.pantheon.terminal.settings natural-copy-paste false

5

For Elementary OS 5.x Juno, it has been set to a new location:

gsettings set io.elementary.terminal.settings natural-copy-paste false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.