10

I would like the lock-screen clock and the wingpanel clock to show seconds. Is this possible?

20

Yes, you can use Dconf-editor or Configurator and go to com.canonical.indicator.datetime and enable show-seconds

Or just paste this in your terminal:

gsettings set com.canonical.indicator.datetime show-seconds true

If you don't want to show seconds anymore you can use this:

gsettings set com.canonical.indicator.datetime show-seconds false
  • 1
    It doesn't work with Loki – Davide May 21 '17 at 12:11
  • Report that on then ;) – Bilal Elmoussaoui May 22 '17 at 12:39
4
gsettings set io.elementary.desktop.wingpanel.datetime clock-show-seconds true
  • Please expand your answer explaining why it's better than the accepted answer. – Maccer Aug 6 at 14:39
  • 1
    elementary OS 5.0 Juno did accept only that form. I've tried the rest and the doesn't work! – VLD Aug 12 at 14:09
  • 1
    This is working on Juno, the accepted answer is not. – Eric Dela Cruz Nov 24 at 4:38
3

When I use that command it says:

No such schema "com.canonical.indicator.datetime"

Edit: the correct setting is:

(under dconf Editor) io.elementary.desktop.wingpanel.datetime -> clock-show-seconds

  • That could have changed in the current release, the problem with the question is that he/she never defined which version is using. In release-juno you are right, this is the key to achieve it – Sebastian Dec 4 '18 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy